Buscar artículos en cambiatealinux.com


Error al actualizar a la última versión de virtualbox


Por Alex el 15/08/2016 , Comentarios: 3

Comparte este artículo:        

Después de actualizar a la ultima versión de virtualbox, al intentar arranca una maquina virtual existente me daba el siguiente error RTR3InitEx failed with rc=-1912 (rc=-1912). Es un problema de versiones, así que se tiene que desinstalar la anterior versión completamente.


El problema fue que desinstalé virtualbox, solamente con la instrucción siguiente:

sudo apt-get autoremove virtualbox


Y esto no eliminó por completo la versión que tenia en el sistema de virtualbox. Después instalé la nueva versión que me había bajado del web de virtualbox

El error que me daba al ejecutar una maquina virtual era el siguiente:

Mensaje de error al arrancar la MV

Ejecutando el comando que dice el mensaje no hizo nada, entonces mire las versiones que tenia instaladas con el siguiente comando:

sudo dpkg -l | grep virtualbox


Y como veis en la imagen

Listado de versiones de virtualbox

hay dos versión, la 5.1 que es la que quiero instalar y la 5.024 que es la antigua, y ese es el error, hay un conflicto de versiones. Entonces eliminamos todo lo referente a virtualbox, todas las versiones:

sudo apt-get remove virtualbox-qt virtualbox-guest-x11 virtualbox-guest-utils virtualbox-guest-dkms virtualbox-dkms virtualbox-5.1 virtualbox


Ejecutar este comando dos veces si la primera vez que lo ejecutáis da el siguiente error:

There were problems setting up VirtualBox. To re-start the set-up process, run
/sbin/vboxconfig
as root.
Se encontraron errores al procesar:
virtualbox-5.1
E: Sub-process /usr/bin/dpkg returned an error code (1)


Reiniciamos el ordenador y después instalamos virtualbox otra vez:

sudo dpkg -i virtualbox-5.1_5.1.2-108956-Ubuntu-xenial_amd64.deb


Y ya funciona correctamente la nueva versión de virtualbox.

Y esto es todo amigos!!
Gracias por seguirme y leerme, espero que les haya ayudado
Saludos
Alex.



Si te ha gustado el artículo compartelo en:        


Publicidad


Añadir un comentarios:

Nombre:
Email: (no se publica el email)

avatar

Azrael 02/01/2017 06:29:37

Gracias! Me funciono 10 puntos!!

avatar

Luis Miguel 19/01/2017 13:45:07

Ostras tio, tenia una version obsoleta en el repositorio de ubuntu. Bendito grep!!Llevaba intentando que me funcionaran las maquinas virtuales y nada. Habia probado varias soluciones y ninguna. Hasta que tope con esta y de repente todo es magico lol xD
gracias tio

namasté

avatar

Alejandro Román 12/01/2018 06:02:37

Magnifico , excelente , maravilloso . Llevo todo el dia con el problema y me lo ha resuelto todo , excelente explicación de todo el proceso para arreglar este fallo . Gracias por toda la ayuda .





Publicidad



RECOMENDADOS


LOS MAS LEÍDOS


CATEGORÍAS
ARCHIVO